吾爱破解 - LCG - LSG |安卓破解|病毒分析|www.52pojie.cn

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

查看: 7112|回复: 44
收起左侧

[KeyGenMe] 都说吾爱大牛多,不知道有没有可做出算法的大牛。

[复制链接]
wintop 发表于 2021-11-29 09:51
CM是什么?Crackme是什么?这是什么东西?楼主发的什么?
他们都是一些公开给别人尝试破解的小程序,制作 Crackme 的人可能是程序员,想测试一下自己的软件保护技术,也可能是一位 Cracker,想挑战一下其它 Cracker 的破解实力,也可能是一些正在学习破解的人,自己编一些小程序给自己破解,KeyGenMe是要求别人做出它的 keygen (序号产生器), ReverseMe 要求别人把它的算法做出逆向分析, UnpackMe 是要求别人把它成功脱壳,本版块禁止回复非技术无关水贴。

本帖最后由 wintop 于 2021-11-29 10:51 编辑

程序易语言写的,没加壳。
希望有大牛能做出来,最好能写下思路,毕竟这块大家都喜欢学习!
先感谢大牛了!

补充下,今天匆忙写的,结果有处算法bug,注册码不是纯数字。还请大牛见谅!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x

免费评分

参与人数 2吾爱币 +10 热心值 +2 收起 理由
20211111qw + 1 热心回复!
涛之雨 + 10 + 1 感谢发布原创作品,吾爱破解论坛因你更精彩!

查看全部评分

发帖前要善用论坛搜索功能,那里可能会有你要找的答案或者已经有人发布过相同内容了,请勿重复发帖。

囚徒灬 发表于 2021-11-29 16:52
de1fnjbh2iop4a0cde1f5m3klde1fh2i

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x

免费评分

参与人数 5吾爱币 +5 热心值 +5 收起 理由
DMSama + 1 + 1 我很赞同!
朝太阳奔跑 + 1 + 1 我很赞同!
Bidui + 1 我很赞同!
FleTime + 3 + 1 用心讨论,共获提升!
wintop + 1 我很赞同!

查看全部评分

paxj168 发表于 2021-11-30 11:06
1、加入OD后搜索注册,结果没有相关字符串,
2、易语言有一个通用的按钮断点,按ALT+M,搜索FF 55 FC 5F 5E 89 5D F4,下断点,
3、运行,输入字符串,随便
4、
[Asm] 纯文本查看 复制代码
0040116F  |.  E8 90FEFFFF   call keygenme.0040100400401174  |.  83C4 08       add esp,0x8
00401177  |.  83F8 00       cmp eax,0x0
0040117A  |.  B8 00000000   mov eax,0x0
0040117F  |.  0F94C0        sete al
00401182  |.  8945 F0       mov [local.4],eax
00401185  |.  8B5D F4       mov ebx,[local.3]
00401188  |.  85DB          test ebx,ebx
0040118A  |.  74 09         je short keygenme.00401195
0040118C  |.  53            push ebx
0040118D  |.  E8 624F0000   call keygenme.004060F4
00401192  |.  83C4 04       add esp,0x4
00401195  |>  837D F0 00    cmp [local.4],0x0
00401199  |.  0F84 8C000000 je keygenme.0040122B
0040119F  |.  B8 ECDE4900   mov eax,keygenme.0049DEEC                ;  dobug
004011A4  |.  8945 F8       mov [local.2],eax
004011A7  |.  8D45 F8       lea eax,[local.2]
004011AA  |.  50            push eax
004011AB  |.  B8 F2DE4900   mov eax,keygenme.0049DEF2                ;  A3D9A9B6C7B2A2F1C286326B8
004011B0  |.  8945 F4       mov [local.3],eax
004011B3  |.  8D45 F4       lea eax,[local.3]
004011B6  |.  50            push eax
004011B7  |.  E8 703E0000   call keygenme.0040502C



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x
weikun444 发表于 2021-11-29 10:25

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x

免费评分

参与人数 2吾爱币 +4 热心值 +2 收起 理由
爷笑了 + 1 欢迎分析讨论交流,吾爱破解论坛有你更精彩!
涛之雨 + 4 + 1 欢迎分析讨论交流,吾爱破解论坛有你更精彩!

查看全部评分

spcspcspcspcspc 发表于 2021-12-8 08:11



目前可以抓取数字密码和字母密码,用内存读取所以报毒。
自写算法出两个结果,怎么判断哪个正确的破不出来了,两个有一个是对的,先这样吧。。。
填写超过7位中文,自写算法都不对,应该程序有其他规则,先不搞了。。。
原程序有不少bug,例如填写1和2,数字密码0141002760会失败,字母密码就能通过。。。怀疑跟第一位是0有关系。
先运行KeyGenMe,在运行KeyGenYou,否则容易卡死。


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x
ReLoading 发表于 2021-11-29 15:38

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x
caiji1 发表于 2021-12-15 21:39
直接易语言按钮断点

然后在这里断下,跟进

这里跳转一定要跳过去

向下的这个跳转也要跳过去

然后从CALL出来,向下就到了最后的关键处

成功

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册[Register]

x

免费评分

参与人数 1吾爱币 +2 热心值 +1 收起 理由
qianshang666 + 2 + 1 我很赞同!

查看全部评分

搜索曾经的回忆 发表于 2021-12-3 18:15
.版本 2

.子程序 getFlag, 文本型, , 解flag
.参数 text, 文本型
.局部变量 res, 文本型
.局部变量 tmp, 字节集
.局部变量 key, 文本型, , "10"
.局部变量 i

tmp = 到字节集 (text)
key = { “a0c”, “njb”, “7y9”, “z8x”, “v6tu”, “rq5s”, “op4”, “m3kl”, “h2i”, “de1f” }
.计次循环首 (取字节集长度 (tmp), i)
    res = key [tmp [i] - 48 + 1] + res
.计次循环尾 ()
返回 (res)

免费评分

参与人数 1吾爱币 +1 收起 理由
wintop + 1 我很赞同!

查看全部评分

 楼主| wintop 发表于 2021-11-29 18:07
囚徒灬 发表于 2021-11-29 16:52
de1fnjbh2iop4a0cde1f5m3klde1fh2i

de1fnjbh2iop4a0cde1frq5sm3klde1fh2i
 楼主| wintop 发表于 2021-11-29 10:30

太牛了,很厉害!
好像我忘记验证是否是纯数字了,注册码不是纯数字....

这样也很牛了!
头像被屏蔽
nur11111 发表于 2021-11-29 13:31
提示: 该帖被管理员或版主屏蔽
头像被屏蔽
sjfaimi123 发表于 2021-11-29 14:15
提示: 该帖被管理员或版主屏蔽
头像被屏蔽
finger99 发表于 2021-11-29 14:18
提示: 该帖被管理员或版主屏蔽
头像被屏蔽
benmagic 发表于 2021-11-29 15:05
提示: 该帖被管理员或版主屏蔽
头像被屏蔽
rangersxiaoyan 发表于 2021-11-29 15:40
提示: 该帖被管理员或版主屏蔽
头像被屏蔽
SoDump 发表于 2021-11-29 15:50
提示: 该帖被管理员或版主屏蔽
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则 警告:本版块禁止回复与主题无关非技术内容,违者重罚!

快速回复 收藏帖子 返回列表 搜索

RSS订阅|小黑屋|处罚记录|联系我们|吾爱破解 - LCG - LSG ( 京ICP备16042023号 | 京公网安备 11010502030087号 )

GMT+8, 2022-9-27 21:31

Powered by Discuz!

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表