吾爱破解 - LCG - LSG |安卓破解|病毒分析|www.52pojie.cn

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

搜索
查看: 1529|回复: 11

[KeyGenMe] 一个有点难度的易语言KeyGenME,欢迎大佬Crack

[复制链接]
xieyi1393 发表于 2020-5-21 21:15
CM是什么?Crackme是什么?这是什么东西?楼主发的什么?
他们都是一些公开给别人尝试破解的小程序,制作 Crackme 的人可能是程序员,想测试一下自己的软件保护技术,也可能是一位 Cracker,想挑战一下其它 Cracker 的破解实力,也可能是一些正在学习破解的人,自己编一些小程序给自己破解,KeyGenMe是要求别人做出它的 keygen (序号产生器), ReverseMe 要求别人把它的算法做出逆向分析, UnpackMe 是要求别人把它成功脱壳,本版块禁止回复非技术无关水贴。

本帖最后由 xieyi1393 于 2020-5-21 22:44 编辑

测试用户名:xieyi1393
测试序列号:640A0C83AADCC5E88A741CEB1F9DE9C9
正确弹出"注册成功,欢迎使用"
错误弹出“注册码不对哦”
奖励40CB,仅限首位CRACK
注意:提交时请同时提交KeyGen代码,否则无效!
蓝廋(奏)云:https://xieyi1393.lanzous.com/icvditi

易语言编写,可能报毒
不要爆破!
注意:提交时请同时提交KeyGen代码,否则无效!

免费评分

参与人数 4吾爱币 +9 热心值 +4 收起 理由
印象主义协会 + 1 + 1 我很赞同!
dreamlivemeng + 1 + 1 鼓励转贴优秀软件安全工具和文档!
CrazyNut + 6 + 1 下次请带上成功截图
为之奈何? + 1 + 1 我很赞同!

查看全部评分

发帖前要善用论坛搜索功能,那里可能会有你要找的答案或者已经有人发布过相同内容了,请勿重复发帖。

banik123 发表于 2020-5-22 00:09
.版本 2
.支持库 dp1

.子程序 getkey, 文本型
.参数 名称, 文本型
.局部变量 a, 文本型
.局部变量 i, 整数型
.局部变量 c, 文本型

i = 1
a = 取数据摘要 (到字节集 (“吾爱破解|LCG|LSG|xieyi1393|https://www.52pojie.cn/home.php?mod=space&uid=1397448” + 名称 + “0吾爱破解”))
.判断循环首 (i < 40960)
    .如果 (i % 3 = 0)
        a = 取数据摘要 (到字节集 (a + 名称 + 到文本 (i) + “吾爱破解”))
    .否则
        .如果 (i % 3 = 1)
            a = 取数据摘要 (到字节集 (a + 名称 + 到文本 (i) + “LCG”))
        .否则
            .如果 (i % 3 = 2)
                a = 取数据摘要 (到字节集 (a + 名称 + 到文本 (i) + “LSG”))
            .否则

            .如果结束

        .如果结束

    .如果结束
    i = i + 1
.判断循环尾 ()
' 调试输出 (字节集_还原 (a))
a = 取数据摘要 (到字节集 (“H@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“y@” + a))
a = 取数据摘要 (到字节集 (“!@” + a))
a = 取数据摘要 (到字节集 (“Y@” + a))
a = 取数据摘要 (到字节集 (“o@” + a))
a = 取数据摘要 (到字节集 (“u@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“F@” + a))
a = 取数据摘要 (到字节集 (“o@” + a))
a = 取数据摘要 (到字节集 (“u@” + a))
a = 取数据摘要 (到字节集 (“n@” + a))
a = 取数据摘要 (到字节集 (“d@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“T@” + a))
a = 取数据摘要 (到字节集 (“h@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“H@” + a))
a = 取数据摘要 (到字节集 (“i@” + a))
a = 取数据摘要 (到字节集 (“d@” + a))
a = 取数据摘要 (到字节集 (“d@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“n@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“K@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“y@” + a))
a = 取数据摘要 (到字节集 (“!@” + a))
a = 取数据摘要 (到字节集 (“J@” + a))
a = 取数据摘要 (到字节集 (“u@” + a))
a = 取数据摘要 (到字节集 (“s@” + a))
a = 取数据摘要 (到字节集 (“t@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“W@” + a))
a = 取数据摘要 (到字节集 (“r@” + a))
a = 取数据摘要 (到字节集 (“i@” + a))
a = 取数据摘要 (到字节集 (“t@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“K@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“y@” + a))
a = 取数据摘要 (到字节集 (“G@” + a))
a = 取数据摘要 (到字节集 (“e@” + a))
a = 取数据摘要 (到字节集 (“n@” + a))
a = 取数据摘要 (到字节集 (“ @” + a))
a = 取数据摘要 (到字节集 (“N@” + a))
a = 取数据摘要 (到字节集 (“o@” + a))
a = 取数据摘要 (到字节集 (“w@” + a))
a = 取数据摘要 (到字节集 (“!@” + a))
c = a
a = 取数据摘要 (到字节集 (“PHP是世界上最好的语言,吾爱是世界上最牛X的PJ论坛” + a))
.判断循环首 (取文本左边 (a, 2) ≠ “88”)
    a = 取数据摘要 (到字节集 (a))
.判断循环尾 ()
a = 取数据摘要 (到字节集 (a + “WWW.52POJIE.CN”))
.判断循环首 (取文本左边 (a, 2) ≠ “66”)
    a = 取数据摘要 (到字节集 (a))

.判断循环尾 ()
a = 取数据摘要 (到字节集 (a + c + “XIEYI1393”))
.判断循环首 (取文本左边 (a, 1) ≠ “4”)
    a = 取数据摘要 (到字节集 (a))

.判断循环尾 ()
a = 取数据摘要 (到字节集 (a + “REDSTONEFUN”))
.判断循环首 (取文本左边 (a, 2) ≠ “64”)
    a = 取数据摘要 (到字节集 (a))

.判断循环尾 ()

返回 (到大写 (a))

 楼主| xieyi1393 发表于 2020-5-22 00:26
本帖最后由 xieyi1393 于 2020-5-22 00:29 编辑
banik123 发表于 2020-5-22 00:09
.版本 2
.支持库 dp1

KeyGen看上去没问题(由于电脑关机了)
各个Point也给找出来了(主要是利用数组隐藏的一组给找出来了)
只是这个KeyGen其实可以写的简洁一点(多用点循环)
不过,请查收40CB:
https://www.52pojie.cn/thread-1184142-1-1.html
陨落星辰 发表于 2020-5-21 22:07
本帖最后由 陨落星辰 于 2020-5-21 22:34 编辑

QQ图片20200521220606.png
不要CB 先手爆破
选中地址处改nop 即可

更新时间:2020.5.21 22点33分
能把KEY追出来我就懒得追算法了

账号:陨落星辰
KEY:64076CA353A2D3CD3275AFC236FDC76A
跌宕起伏 发表于 2020-5-21 22:38
QQ截图20200521223622.png
Patches
地址       大小   状态      旧                                新                                注释
00401293     2.   激活        ???                               jmp XKeyGenMe.004012E3        CDKEY为32位大写字母/数字
0040240F     6.   激活        je KeyGenMe.0040245F              nop                 注册成功
除了加了壳加了花感觉难度不大
 楼主| xieyi1393 发表于 2020-5-21 22:42
陨落星辰 发表于 2020-5-21 22:07
不要CB 先手爆破
选中地址处改nop 即可

Key正确,请给出KeyGen代码
 楼主| xieyi1393 发表于 2020-5-21 22:43
跌宕起伏 发表于 2020-5-21 22:38
Patches
地址       大小   状态      旧                                新                          ...

请给出KeyGen代码
basstk 发表于 2020-5-21 23:27
都是大佬.学习了
Light紫星 发表于 2020-5-22 10:46
banik123 发表于 2020-5-22 00:09
.版本 2
.支持库 dp1

大佬是怎么搞出来源码的
a110pk147 发表于 2020-5-22 15:18
都(与)是(我)大(无)佬(关)
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则 警告:本版块禁止回复与主题无关非技术内容,违者重罚!

快速回复 收藏帖子 返回列表 搜索

RSS订阅|小黑屋|联系我们|吾爱破解 - LCG - LSG ( 京ICP备16042023号 | 京公网安备 11010502030087号 )

GMT+8, 2020-5-27 14:05

Powered by Discuz!

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表