吾爱破解 - LCG - LSG |安卓破解|病毒分析|www.52pojie.cn

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

搜索
查看: 713|回复: 11
收起左侧

易语言图片框,上一张,下一张,怎么写

[复制链接]
cuantianhou888 发表于 2020-2-7 12:20
50吾爱币
易语言图片框,点击上一张按钮,切换到上一张,点击下一张按钮,切换到下一张
大约100张图片,http读文件

最佳答案

查看完整内容

你得把他所有得图片或者图片地址放一个数组里面,通过读取数组下标+1 -1 这种效果来取数组里对应得图片或者图片地址。

发帖前要善用论坛搜索功能,那里可能会有你要找的答案或者已经有人发布过相同内容了,请勿重复发帖。

米饭大师 发表于 2020-2-7 12:20

你得把他所有得图片或者图片地址放一个数组里面,通过读取数组下标+1  -1 这种效果来取数组里对应得图片或者图片地址。
小诺宝 发表于 2020-2-7 12:29
比较笨的方法  读取所以照片地址到列表里    点按钮来读取列表里的地址
米饭大师 发表于 2020-2-7 12:34
 楼主| cuantianhou888 发表于 2020-2-7 12:37
小诺宝 发表于 2020-2-7 12:29
比较笨的方法  读取所以照片地址到列表里    点按钮来读取列表里的地址

[Asm] 纯文本查看 复制代码
.版本 2
.支持库 internet

.子程序 _按钮2_被单击
.局部变量 NN

NN = NN + 1
.如果真 (NN > 5)

.如果真结束
NN = 1
图片框1.图片 = 多项选择 (NN, HTTP读文件 (“http://www.hydcd.com/cy/fkccy/images/CF91100-51.png”))
 楼主| cuantianhou888 发表于 2020-2-7 12:38
小诺宝 发表于 2020-2-7 12:29
比较笨的方法  读取所以照片地址到列表里    点按钮来读取列表里的地址

怎么读取多个,我现在写的只能读取一个
 楼主| cuantianhou888 发表于 2020-2-7 12:42
米饭大师 发表于 2020-2-7 12:34
那你得用数组把图片存起来

那该怎么写
 楼主| cuantianhou888 发表于 2020-2-7 13:00
米饭大师 发表于 2020-2-7 12:48
你得把他所有得图片或者图片地址放一个数组里面,通过读取数组下标+1  -1 这种效果来取数组里对应得图片 ...

怎么放到数组啊,能写个例子吗
Homely 发表于 2020-2-7 13:41
cuantianhou888 发表于 2020-2-7 13:00
怎么放到数组啊,能写个例子吗

我看你这个图片是有规律的啊
http://www.hydcd.com/cy/fkccy/images/CF91100-52.png
51   52能打开  怎么后面没有了。  要是有规律就很好写了       把中间变量&连接   减少特别多工作量

例如
“http//www.dddddd”&“51”&“.html”
我的爱是你 发表于 2020-2-7 13:48
本帖最后由 我的爱是你 于 2020-2-7 13:50 编辑

http的话保存全部地址,需要时再访问。
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则 警告:本版块禁止灌水或回复与主题无关内容,违者重罚!

快速回复 收藏帖子 返回列表 搜索

RSS订阅|小黑屋|处罚记录|联系我们|吾爱破解 - LCG - LSG ( 京ICP备16042023号 | 京公网安备 11010502030087号 )

GMT+8, 2021-3-1 19:00

Powered by Discuz!

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表